CVE-2023-46316

NameCVE-2023-46316
DescriptionIn buc Traceroute 2.0.12 through 2.1.2 before 2.1.3, the wrapper scripts do not properly parse command lines.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
traceroute (PTS)buster1:2.1.0-2vulnerable
bullseye1:2.1.0-2+deb11u1vulnerable
bookworm1:2.1.2-1vulnerable
trixie, sid1:2.1.5-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
traceroutesource(unstable)1:2.1.3-1

Notes

[bookworm] - traceroute <no-dsa> (Minor issue)
[bullseye] - traceroute <no-dsa> (Minor issue)
[buster] - traceroute <no-dsa> (Minor issue)
https://sourceforge.net/projects/traceroute/files/traceroute/traceroute-2.1.3/

Search for package or bug name: Reporting problems