CVE-2023-46849

NameCVE-2023-46849
DescriptionUsing the --fragment option in certain configuration setups OpenVPN version 2.6.0 to 2.6.6 allows an attacker to trigger a divide by zero behaviour which could cause an application crash, leading to a denial of service.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
ReferencesDSA-5555-1
Debian Bugs1055805

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
openvpn (PTS)bullseye2.5.1-3fixed
bookworm, bookworm (security)2.6.3-1+deb12u2fixed
sid, trixie2.6.11-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
openvpnsourcebuster(not affected)
openvpnsourcebullseye(not affected)
openvpnsourcebookworm2.6.3-1+deb12u2DSA-5555-1
openvpnsource(unstable)2.6.7-11055805

Notes

[bullseye] - openvpn <not-affected> (Vulnerable code not present)
[buster] - openvpn <not-affected> (Vulnerable code not present)
https://community.openvpn.net/openvpn/wiki/CVE-2023-46849
https://openvpn.net/security-advisory/access-server-security-update-cve-2023-46849-cve-2023-46850/
Fixed by: https://github.com/OpenVPN/openvpn/commit/1cfca659244e362f372d9843351257f456392a2f (v2.6.7)

Search for package or bug name: Reporting problems