DescriptionCross Site Scripting vulnerability in BootBox Bootbox.js v.3.2 through 6.0 allows a remote attacker to execute arbitrary code via a crafted payload to alert(), confirm(), prompt() functions.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
Debian Bugs1055612

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libjs-bootbox (PTS)buster4.4.0~dfsg-1vulnerable
sid, trixie, bookworm5.5.3~ds-1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs


[bookworm] - libjs-bootbox <no-dsa> (Minor issue)
[bullseye] - libjs-bootbox <no-dsa> (Minor issue)
[buster] - libjs-bootbox <postponed> (Minor issue, reflected XSS)

Search for package or bug name: Reporting problems