CVE-2023-4734

NameCVE-2023-4734
DescriptionInteger Overflow or Wraparound in GitHub repository vim/vim prior to 9.0.1846.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
vim (PTS)buster2:8.1.0875-5+deb10u2vulnerable
buster (security)2:8.1.0875-5+deb10u6vulnerable
bullseye2:8.2.2434-3+deb11u1vulnerable
bookworm2:9.0.1378-2vulnerable
trixie, sid2:9.1.0377-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
vimsource(unstable)2:9.0.1894-1unimportant

Notes

https://huntr.dev/bounties/688e4382-d2b6-439a-a54e-484780f82217/
https://github.com/vim/vim/commit/4c6fe2e2ea62469642ed1d80b16d39e616b25cf5 (v9.0.1846)
Crash in CLI tool, no security impact

Search for package or bug name: Reporting problems