CVE-2023-47360

NameCVE-2023-47360
DescriptionVideolan VLC prior to version 3.0.20 contains an Integer underflow that leads to an incorrect packet length.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
ReferencesDLA-3679-1, DSA-5545-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
vlc (PTS)buster3.0.17.4-0+deb10u1vulnerable
buster (security)3.0.20-0+deb10u1fixed
bullseye3.0.20-0+deb11u1fixed
bullseye (security)3.0.21-0+deb11u1fixed
bookworm3.0.20-0+deb12u1fixed
bookworm (security)3.0.21-0+deb12u1fixed
sid, trixie3.0.21-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
vlcsourcebuster3.0.20-0+deb10u1DLA-3679-1
vlcsourcebullseye3.0.20-0+deb11u1DSA-5545-1
vlcsourcebookworm3.0.20-0+deb12u1DSA-5545-1
vlcsource(unstable)3.0.20-1

Notes

https://0xariana.github.io/blog/real_bugs/vlc/mms
https://code.videolan.org/videolan/vlc/-/commit/27840cb5b20bc4651ba6af01d0a7ae6da17297ef

Search for package or bug name: Reporting problems