CVE-2023-49288

NameCVE-2023-49288
DescriptionSquid is a caching proxy for the Web supporting HTTP, HTTPS, FTP, and more. Affected versions of squid are subject to a a Use-After-Free bug which can lead to a Denial of Service attack via collapsed forwarding. All versions of Squid from 3.5 up to and including 5.9 configured with "collapsed_forwarding on" are vulnerable. Configurations with "collapsed_forwarding off" or without a "collapsed_forwarding" directive are not vulnerable. This bug is fixed by Squid version 6.0.1. Users are advised to upgrade. Users unable to upgrade should remove all collapsed_forwarding lines from their squid.conf.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
squid (PTS)buster4.6-1+deb10u7vulnerable
buster (security)4.6-1+deb10u10vulnerable
bullseye4.13-10+deb11u2vulnerable
bullseye (security)4.13-10+deb11u3vulnerable
bookworm5.7-2vulnerable
bookworm (security)5.7-2+deb12u1vulnerable
sid, trixie6.9-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
squidsource(unstable)6.1-1
squid3source(unstable)(unfixed)

Notes

https://github.com/squid-cache/squid/security/advisories/GHSA-rj5h-46j6-q2g5
https://megamansec.github.io/Squid-Security-Audit/trace-uaf.html
https://github.com/squid-cache/squid/pull/1127 possibly removed the vulnerable code.

Search for package or bug name: Reporting problems