CVE-2023-49558

NameCVE-2023-49558
DescriptionAn issue in YASM 1.3.0.86.g9def allows a remote attacker to cause a denial of service via the expand_mmac_params function in the modules/preprocs/nasm/nasm-pp.c component.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
yasm (PTS)buster1.3.0-2vulnerable
bullseye1.3.0-2.1vulnerable
sid, trixie, bookworm1.3.0-4vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
yasmsource(unstable)(unfixed)unimportant

Notes

Crash in CLI tool, no security impact
https://github.com/yasm/yasm/issues/252

Search for package or bug name: Reporting problems