CVE-2023-50471

NameCVE-2023-50471
DescriptioncJSON v1.7.16 was discovered to contain a segmentation violation via the function cJSON_InsertItemInArray at cJSON.c.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
ReferencesDLA-3700-1
Debian Bugs1059287

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
cjson (PTS)buster1.7.10-1.1+deb10u1vulnerable
buster (security)1.7.10-1.1+deb10u2fixed
bullseye1.7.14-1vulnerable
bookworm1.7.15-1vulnerable
sid, trixie1.7.17-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
cjsonsourcebuster1.7.10-1.1+deb10u2DLA-3700-1
cjsonsource(unstable)1.7.17-11059287

Notes

https://github.com/DaveGamble/cJSON/issues/802
Fixed by: https://github.com/DaveGamble/cJSON/commit/60ff122ef5862d04b39b150541459e7f5e35add8

Search for package or bug name: Reporting problems