CVE-2023-50472

NameCVE-2023-50472
DescriptioncJSON v1.7.16 was discovered to contain a segmentation violation via the function cJSON_SetValuestring at cJSON.c.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
Debian Bugs1059287

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
cjson (PTS)buster1.7.10-1.1+deb10u1fixed
buster (security)1.7.10-1.1+deb10u2fixed
bullseye1.7.14-1vulnerable
bookworm1.7.15-1vulnerable
sid, trixie1.7.17-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
cjsonsourcebuster(not affected)
cjsonsource(unstable)1.7.17-1unimportant1059287

Notes

[buster] - cjson <not-affected> (Vulnerable code introduced later)
https://github.com/DaveGamble/cJSON/issues/803
Fixed by: https://github.com/DaveGamble/cJSON/commit/60ff122ef5862d04b39b150541459e7f5e35add8
Seems bogus, this isn't a DoS but only a broken use of an API

Search for package or bug name: Reporting problems