CVE-2023-50980

NameCVE-2023-50980
Descriptiongf2n.cpp in Crypto++ (aka cryptopp) through 8.9.0 allows attackers to cause a denial of service (application crash) via DER public-key data for an F(2^m) curve, if the degree of each term in the polynomial is not strictly decreasing.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
Debian Bugs1059311

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libcrypto++ (PTS)buster5.6.4-8vulnerable
bullseye8.4.0-1vulnerable
bookworm8.7.0+git220824-1vulnerable
trixie8.9.0-1vulnerable
sid8.9.0-1.1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libcrypto++source(unstable)(unfixed)1059311

Notes

[bookworm] - libcrypto++ <no-dsa> (Minor issue)
[bullseye] - libcrypto++ <no-dsa> (Minor issue)
[buster] - libcrypto++ <no-dsa> (Minor issue)
https://github.com/weidai11/cryptopp/issues/1248

Search for package or bug name: Reporting problems