CVE-2023-51074

NameCVE-2023-51074
Descriptionjson-path v2.8.0 was discovered to contain a stack overflow via the Criteria.parse() method.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
Debian Bugs1072123

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
jayway-jsonpath (PTS)sid, trixie, buster, bookworm, bullseye2.0.0-5vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
jayway-jsonpathsource(unstable)(unfixed)1072123

Notes

[bookworm] - jayway-jsonpath <no-dsa> (Minor issue)
[bullseye] - jayway-jsonpath <no-dsa> (Minor issue)
[buster] - jayway-jsonpath <no-dsa> (Minor issue)
https://github.com/json-path/JsonPath/issues/973
https://github.com/json-path/JsonPath/commit/71a09c1193726c010917f1157ecbb069ad6c3e3b (json-path-2.9.0)
https://github.com/json-path/JsonPath/pull/985

Search for package or bug name: Reporting problems