CVE-2023-5115

NameCVE-2023-5115
DescriptionAn absolute path traversal attack exists in the Ansible automation platform. This flaw allows an attacker to craft a malicious Ansible role and make the victim execute the role. A symlink can be used to overwrite a file outside of the extraction path.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
ReferencesDLA-3695-1
Debian Bugs1053693

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
ansible (PTS)bullseye2.10.7+merged+base+2.10.8+dfsg-1vulnerable
bookworm7.3.0+dfsg-1fixed
sid, trixie10.1.0+dfsg-1fixed
ansible-core (PTS)bookworm2.14.3-1vulnerable
sid, trixie2.17.1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
ansiblesourcebuster2.7.7+dfsg-1+deb10u2DLA-3695-1
ansiblesource(unstable)5.4.0-1
ansible-coresource(unstable)2.14.11-11053693

Notes

[bookworm] - ansible-core <no-dsa> (Minor issue)
[bullseye] - ansible-core <no-dsa> (Minor issue)
[bullseye] - ansible <no-dsa> (Minor issue)
https://bugzilla.redhat.com/show_bug.cgi?id=2233810
https://github.com/ansible/ansible/pull/81780
https://github.com/ansible/ansible/commit/ddf0311c63287e2d5334770377350c1e0cbfff28
ansible-core was split off from src:ansible with 4.6.0-1 in experimental/5.4.0-1 in sid

Search for package or bug name: Reporting problems