CVE-2023-5169

NameCVE-2023-5169
DescriptionA compromised content process could have provided malicious data in a `PathRecording` resulting in an out-of-bounds write, leading to a potentially exploitable crash in a privileged process. This vulnerability affects Firefox < 118, Firefox ESR < 115.3, and Thunderbird < 115.3.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
ReferencesDLA-3587-1, DLA-3601-1, DSA-5506-1, DSA-5513-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
firefox (PTS)sid128.0-1fixed
firefox-esr (PTS)bullseye115.12.0esr-1~deb11u1fixed
bullseye (security)115.13.0esr-1~deb11u1fixed
bookworm115.12.0esr-1~deb12u1fixed
bookworm (security)115.13.0esr-1~deb12u1fixed
trixie115.12.0esr-1fixed
sid115.13.0esr-1fixed
thunderbird (PTS)bullseye1:115.12.0-1~deb11u1fixed
bullseye (security)1:115.13.0-1~deb11u1fixed
bookworm1:115.12.0-1~deb12u1fixed
bookworm (security)1:115.13.0-1~deb12u1fixed
trixie1:115.12.0-1fixed
sid1:115.13.0-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
firefoxsource(unstable)118.0-1
firefox-esrsourcebuster115.3.0esr-1~deb10u1DLA-3587-1
firefox-esrsourcebullseye115.3.0esr-1~deb11u1DSA-5506-1
firefox-esrsourcebookworm115.3.0esr-1~deb12u1DSA-5506-1
firefox-esrsource(unstable)115.3.0esr-1
thunderbirdsourcebuster1:115.3.1-1~deb10u1DLA-3601-1
thunderbirdsourcebullseye1:115.3.1-1~deb11u1DSA-5513-1
thunderbirdsourcebookworm1:115.3.1-1~deb12u1DSA-5513-1
thunderbirdsource(unstable)1:115.3.0-1

Notes

https://www.mozilla.org/en-US/security/advisories/mfsa2023-41/#CVE-2023-5169
https://www.mozilla.org/en-US/security/advisories/mfsa2023-42/#CVE-2023-5169
https://www.mozilla.org/en-US/security/advisories/mfsa2023-43/#CVE-2023-5169

Search for package or bug name: Reporting problems