CVE-2023-51704

NameCVE-2023-51704
DescriptionAn issue was discovered in MediaWiki before 1.35.14, 1.36.x through 1.39.x before 1.39.6, and 1.40.x before 1.40.2. In includes/logging/RightsLogFormatter.php, group-*-member messages can result in XSS on Special:log/rights.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
mediawiki (PTS)buster1:1.31.16-1+deb10u2vulnerable
buster (security)1:1.31.16-1+deb10u7vulnerable
bullseye (security), bullseye1:1.35.13-1~deb11u1vulnerable
bookworm, bookworm (security)1:1.39.5-1~deb12u1vulnerable
trixie, sid1:1.39.6-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
mediawikisource(unstable)1:1.39.6-1

Notes

[bookworm] - mediawiki <postponed> (Minor issue, fix along in next update)
[bullseye] - mediawiki <postponed> (Minor issue, fix along in next update)
[buster] - mediawiki <postponed> (Minor issue, fix along in next update)
https://lists.wikimedia.org/hyperkitty/list/wikitech-l@lists.wikimedia.org/thread/TDBUBCCOQJUT4SCHJNPHKQNPBUUETY52/
https://phabricator.wikimedia.org/T347726

Search for package or bug name: Reporting problems