CVE-2023-52138

NameCVE-2023-52138
DescriptionEngrampa is an archive manager for the MATE environment. Engrampa is found to be vulnerable to a Path Traversal vulnerability that can be leveraged to achieve full Remote Command Execution (RCE) on the target. While handling CPIO archives, the Engrampa Archive manager follows symlink, cpio by default will follow stored symlinks while extracting and the Archiver will not check the symlink location, which leads to arbitrary file writes to unintended locations. When the victim extracts the archive, the attacker can craft a malicious cpio or ISO archive to achieve RCE on the target system. This vulnerability was fixed in commit 63d5dfa.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
ReferencesDLA-3741-1, DSA-5625-1
Debian Bugs1063494

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
engrampa (PTS)buster1.20.2-1vulnerable
buster (security)1.20.2-1+deb10u1fixed
bullseye1.24.1-1vulnerable
bullseye (security)1.24.1-1+deb11u1fixed
bookworm1.26.0-1+deb12u1vulnerable
bookworm (security)1.26.0-1+deb12u2fixed
sid, trixie1.26.2-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
engrampasourcebuster1.20.2-1+deb10u1DLA-3741-1
engrampasourcebullseye1.24.1-1+deb11u1DSA-5625-1
engrampasourcebookworm1.26.0-1+deb12u2DSA-5625-1
engrampasource(unstable)1.26.2-11063494

Notes

https://github.com/mate-desktop/engrampa/security/advisories/GHSA-c98h-v39w-3r7v
https://github.com/mate-desktop/engrampa/commit/63d5dfa9005c6b16d0f0ccd888cc859fca78f970

Search for package or bug name: Reporting problems