CVE-2023-52353

NameCVE-2023-52353
DescriptionAn issue was discovered in Mbed TLS through 3.5.1. In mbedtls_ssl_session_reset, the maximum negotiable TLS version is mishandled. For example, if the last connection negotiated TLS 1.2, then 1.2 becomes the new maximum.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
mbedtls (PTS)buster2.16.0-1fixed
buster (security)2.16.9-0~deb10u1fixed
bullseye2.16.9-0.1fixed
bookworm2.28.3-1fixed
sid, trixie2.28.8-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
mbedtlssource(unstable)(not affected)

Notes

- mbedtls <not-affected> (Vulnerable code not enabled in any build which supports TLS 1.3)
https://github.com/Mbed-TLS/mbedtls/issues/8654
https://github.com/Mbed-TLS/mbedtls/commit/ad736991bb59211118a29fe115367c24495300c2 (mbedtls-3.6.0)
Experimental TLS 1.3 support not enabled in 2.x packages, TLS 1.3 is enabled
in Debian/experimental, but the first upload directly provides fixes, so mark
as <not-affected> altogether

Search for package or bug name: Reporting problems