CVE-2023-52425

NameCVE-2023-52425
Descriptionlibexpat through 2.5.0 allows a denial of service (resource consumption) because many full reparsings are required in the case of a large token for which multiple buffer fills are needed.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
Debian Bugs1063238

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
expat (PTS)buster2.2.6-2+deb10u4vulnerable
buster (security)2.2.6-2+deb10u6vulnerable
bullseye (security), bullseye2.2.10-2+deb11u5vulnerable
bookworm2.5.0-1vulnerable
trixie2.5.0-2vulnerable
sid2.6.0-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
expatsource(unstable)2.6.0-11063238

Notes

https://github.com/libexpat/libexpat/pull/789
Merge commit: https://github.com/libexpat/libexpat/commit/34b598c5f594b015c513c73f06e7ced3323edbf1

Search for package or bug name: Reporting problems