CVE-2023-5344

NameCVE-2023-5344
DescriptionHeap-based Buffer Overflow in GitHub repository vim/vim prior to 9.0.1969.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
Debian Bugs1053694

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
vim (PTS)buster2:8.1.0875-5+deb10u2vulnerable
buster (security)2:8.1.0875-5+deb10u6vulnerable
bullseye2:8.2.2434-3+deb11u1vulnerable
bookworm2:9.0.1378-2vulnerable
trixie, sid2:9.1.0377-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
vimsource(unstable)2:9.0.2018-11053694

Notes

[bookworm] - vim <no-dsa> (Minor issue)
[bullseye] - vim <no-dsa> (Minor issue)
[buster] - vim <postponed> (Minor issue, 1-byte overflow)
https://github.com/vim/vim/commit/3bd7fa12e146c6051490d048a4acbfba974eeb04
https://huntr.dev/bounties/530cb762-899e-48d7-b50e-dad09eb775bf

Search for package or bug name: Reporting problems