CVE-2023-5692

NameCVE-2023-5692
DescriptionWordPress Core is vulnerable to Sensitive Information Exposure in versions up to, and including, 6.4.3 via the redirect_guess_404_permalink function. This can allow unauthenticated attackers to expose the slug of a custom post whose 'publicly_queryable' post status has been set to 'false'.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
wordpress (PTS)buster5.0.15+dfsg1-0+deb10u1vulnerable
buster (security)5.0.21+dfsg1-0+deb10u1vulnerable
bullseye5.7.8+dfsg1-0+deb11u2vulnerable
bullseye (security)5.7.11+dfsg1-0+deb11u1vulnerable
bookworm6.1.1+dfsg1-1vulnerable
bookworm (security)6.1.6+dfsg1-0+deb12u1vulnerable
sid, trixie6.5.3+dfsg1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
wordpresssource(unstable)6.5+dfsg1-1

Notes

https://core.trac.wordpress.org/changeset/57645

Search for package or bug name: Reporting problems