CVE-2023-5841

NameCVE-2023-5841
DescriptionDue to a failure in validating the number of scanline samples of a OpenEXR file containing deep scanline data, Academy Software Foundation OpenEX image parsing library version 3.2.1 and prior is susceptible to a heap-based buffer overflow vulnerability. This issue was resolved as of versions v3.2.2 and v3.1.12 of the affected library.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
Debian Bugs1063414

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
openexr (PTS)buster2.2.1-4.1+deb10u1fixed
buster (security)2.2.1-4.1+deb10u2fixed
bullseye (security), bullseye2.5.4-2+deb11u1fixed
bookworm3.1.5-5vulnerable
trixie, sid3.1.5-5.1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
openexrsourcebuster(not affected)
openexrsourcebullseye(not affected)
openexrsource(unstable)(unfixed)1063414

Notes

[bookworm] - openexr <no-dsa> (Minor issue)
[bullseye] - openexr <not-affected> (Only affects 3.x)
[buster] - openexr <not-affected> (Only affects 3.x)
https://takeonme.org/cves/CVE-2023-5841.html
https://github.com/AcademySoftwareFoundation/openexr/issues/1625
https://github.com/AcademySoftwareFoundation/openexr/commit/46944c3a87ebc6c5d9a9a4962a94569ba1082bc3
https://github.com/AcademySoftwareFoundation/openexr/pull/1627

Search for package or bug name: Reporting problems