CVE-2023-5871

NameCVE-2023-5871
DescriptionA flaw was found in libnbd, due to a malicious Network Block Device (NBD), a protocol for accessing Block Devices such as hard disks over a Network. This issue may allow a malicious NBD server to cause a Denial of Service.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
Debian Bugs1055170

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libnbd (PTS)bullseye1.6.1-1fixed
bookworm1.14.2-1fixed
sid, trixie1.20.1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libnbdsourcebullseye(not affected)
libnbdsourcebookworm(not affected)
libnbdsource(unstable)1.18.1-11055170

Notes

[bookworm] - libnbd <not-affected> (Vulnerable code not present)
[bullseye] - libnbd <not-affected> (Vulnerable code not present)
https://lists.libguestfs.org/archives/list/guestfs@lists.libguestfs.org/thread/PFVUCMPFQUDC23JXSCUUPXIGDZ7XCFMD/
Introduced by: https://gitlab.com/nbdkit/libnbd/-/commit/20dadb0e10fc7236c763e3cf8c55fcc92ef28623 (v1.17.4)
Fixed by: https://gitlab.com/nbdkit/libnbd/-/commit/177308adb17e81fce7c0f2b2fcf655c5c0b6a4d6 (master)
Fixed by: https://gitlab.com/nbdkit/libnbd/-/commit/4451e5b61ca07771ceef3e012223779e7a0c7701 (stable-1.18)

Search for package or bug name: Reporting problems