CVE-2023-6683

NameCVE-2023-6683
DescriptionA flaw was found in the QEMU built-in VNC server while processing ClientCutText messages. The qemu_clipboard_request() function can be reached before vnc_server_cut_text_caps() was called and had the chance to initialize the clipboard peer, leading to a NULL pointer dereference. This could allow a malicious authenticated VNC client to crash QEMU and trigger a denial of service.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
Debian Bugs1060749

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
qemu (PTS)buster1:3.1+dfsg-8+deb10u8vulnerable
buster (security)1:3.1+dfsg-8+deb10u11vulnerable
bullseye1:5.2+dfsg-11+deb11u3vulnerable
bullseye (security)1:5.2+dfsg-11+deb11u2vulnerable
bookworm1:7.2+dfsg-7+deb12u5fixed
trixie, sid1:8.2.1+ds-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
qemusourcebookworm1:7.2+dfsg-7+deb12u4
qemusource(unstable)1:8.2.0+ds-51060749

Notes

[bullseye] - qemu <no-dsa> (Minor issue)
https://bugzilla.redhat.com/show_bug.cgi?id=2254825
Proposed patch: https://lists.nongnu.org/archive/html/qemu-devel/2024-01/msg02382.html

Search for package or bug name: Reporting problems