CVE-2024-0076

NameCVE-2024-0076
DescriptionNVIDIA CUDA toolkit for all platforms contains a vulnerability in cuobjdump and nvdisasm where an attacker may cause a crash by tricking a user into reading a malformed ELF file. A successful exploit of this vulnerability may lead to a partial denial of service.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
Debian Bugs1070177

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
nvidia-cuda-toolkit (PTS)buster/non-free9.2.148-7+deb10u1vulnerable
bullseye/non-free11.2.2-3+deb11u3vulnerable
bookworm/non-free11.8.0-5~deb12u1vulnerable
sid/non-free, trixie/non-free12.1.1-1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
nvidia-cuda-toolkitsource(unstable)(unfixed)1070177

Notes

[bookworm] - nvidia-cuda-toolkit <no-dsa> (Non-free not supported)
[bullseye] - nvidia-cuda-toolkit <no-dsa> (Non-free not supported)
https://nvidia.custhelp.com/app/answers/detail/a_id/5517

Search for package or bug name: Reporting problems