CVE-2024-0553

NameCVE-2024-0553
DescriptionA vulnerability was found in GnuTLS. The response times to malformed ciphertexts in RSA-PSK ClientKeyExchange differ from the response times of ciphertexts with correct PKCS#1 v1.5 padding. This issue may allow a remote attacker to perform a timing side-channel attack in the RSA-PSK key exchange, potentially leading to the leakage of sensitive data. CVE-2024-0553 is designated as an incomplete resolution for CVE-2023-5981.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
ReferencesDLA-3740-1
Debian Bugs1061046

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
gnutls28 (PTS)buster3.6.7-4+deb10u8vulnerable
buster (security)3.6.7-4+deb10u12fixed
bullseye3.7.1-5+deb11u4vulnerable
bullseye (security)3.7.1-5+deb11u3vulnerable
bookworm3.7.9-2+deb12u2fixed
trixie3.8.3-1fixed
sid3.8.5-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
gnutls28sourcebuster3.6.7-4+deb10u12DLA-3740-1
gnutls28sourcebookworm3.7.9-2+deb12u2
gnutls28source(unstable)3.8.3-11061046

Notes

[bullseye] - gnutls28 <no-dsa> (Minor issue; will be fixed in point release)
https://gitlab.com/gnutls/gnutls/-/issues/1522
https://gnutls.org/security-new.html#GNUTLS-SA-2024-01-14
https://gitlab.com/gnutls/gnutls/-/commit/40dbbd8de499668590e8af51a15799fbc430595e (3.8.3)
https://lists.gnupg.org/pipermail/gnutls-help/2024-January/004841.html
Issue exists because of incomplete fix for CVE-2023-5981

Search for package or bug name: Reporting problems