CVE-2024-0742

NameCVE-2024-0742
DescriptionIt was possible for certain browser prompts and dialogs to be activated or dismissed unintentionally by the user due to an incorrect timestamp used to prevent input after page load. This vulnerability affects Firefox < 122, Firefox ESR < 115.7, and Thunderbird < 115.7.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
ReferencesDLA-3720-1, DLA-3727-1, DSA-5605-1, DSA-5606-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
firefox (PTS)sid128.0-1fixed
firefox-esr (PTS)bullseye115.12.0esr-1~deb11u1fixed
bullseye (security)115.13.0esr-1~deb11u1fixed
bookworm115.12.0esr-1~deb12u1fixed
bookworm (security)115.13.0esr-1~deb12u1fixed
trixie115.12.0esr-1fixed
sid115.13.0esr-1fixed
thunderbird (PTS)bullseye1:115.12.0-1~deb11u1fixed
bullseye (security)1:115.13.0-1~deb11u1fixed
bookworm1:115.12.0-1~deb12u1fixed
bookworm (security)1:115.13.0-1~deb12u1fixed
trixie1:115.12.0-1fixed
sid1:115.13.0-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
firefoxsource(unstable)122.0-1
firefox-esrsourcebuster115.7.0esr-1~deb10u1DLA-3727-1
firefox-esrsourcebullseye115.7.0esr-1~deb11u1DSA-5606-1
firefox-esrsourcebookworm115.7.0esr-1~deb12u1DSA-5606-1
firefox-esrsource(unstable)115.7.0esr-1
thunderbirdsourcebuster1:115.7.0-1~deb10u1DLA-3720-1
thunderbirdsourcebullseye1:115.7.0-1~deb11u1DSA-5605-1
thunderbirdsourcebookworm1:115.7.0-1~deb12u1DSA-5605-1
thunderbirdsource(unstable)1:115.7.0-1

Notes

https://www.mozilla.org/en-US/security/advisories/mfsa2024-01/#CVE-2024-0742
https://www.mozilla.org/en-US/security/advisories/mfsa2024-02/#CVE-2024-0742
https://www.mozilla.org/en-US/security/advisories/mfsa2024-04/#CVE-2024-0742

Search for package or bug name: Reporting problems