CVE-2024-0755

NameCVE-2024-0755
DescriptionMemory safety bugs present in Firefox 121, Firefox ESR 115.6, and Thunderbird 115.6. Some of these bugs showed evidence of memory corruption and we presume that with enough effort some of these could have been exploited to run arbitrary code. This vulnerability affects Firefox < 122, Firefox ESR < 115.7, and Thunderbird < 115.7.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
ReferencesDLA-3720-1, DLA-3727-1, DSA-5605-1, DSA-5606-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
firefox (PTS)sid125.0.1-2fixed
firefox-esr (PTS)buster91.12.0esr-1~deb10u1vulnerable
buster (security)115.10.0esr-1~deb10u1fixed
bullseye115.7.0esr-1~deb11u1fixed
bullseye (security)115.10.0esr-1~deb11u1fixed
bookworm115.7.0esr-1~deb12u1fixed
bookworm (security)115.10.0esr-1~deb12u1fixed
trixie115.8.0esr-1fixed
sid115.10.0esr-1fixed
thunderbird (PTS)buster1:91.12.0-1~deb10u1vulnerable
buster (security)1:115.9.0-1~deb10u1fixed
bullseye1:115.7.0-1~deb11u1fixed
bullseye (security)1:115.9.0-1~deb11u1fixed
bookworm1:115.7.0-1~deb12u1fixed
bookworm (security)1:115.9.0-1~deb12u1fixed
sid1:115.9.0-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
firefoxsource(unstable)122.0-1
firefox-esrsourcebuster115.7.0esr-1~deb10u1DLA-3727-1
firefox-esrsourcebullseye115.7.0esr-1~deb11u1DSA-5606-1
firefox-esrsourcebookworm115.7.0esr-1~deb12u1DSA-5606-1
firefox-esrsource(unstable)115.7.0esr-1
thunderbirdsourcebuster1:115.7.0-1~deb10u1DLA-3720-1
thunderbirdsourcebullseye1:115.7.0-1~deb11u1DSA-5605-1
thunderbirdsourcebookworm1:115.7.0-1~deb12u1DSA-5605-1
thunderbirdsource(unstable)1:115.7.0-1

Notes

https://www.mozilla.org/en-US/security/advisories/mfsa2024-01/#CVE-2024-0755
https://www.mozilla.org/en-US/security/advisories/mfsa2024-02/#CVE-2024-0755
https://www.mozilla.org/en-US/security/advisories/mfsa2024-04/#CVE-2024-0755

Search for package or bug name: Reporting problems