CVE-2024-0901

NameCVE-2024-0901
DescriptionRemotely executed SEGV and out of bounds read allows malicious packet sender to crash or cause an out of bounds read via sending a malformed packet with the correct length.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
Debian Bugs1067799

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
wolfssl (PTS)bullseye4.6.0+p1-0+deb11u2vulnerable
bookworm5.5.4-2+deb12u1vulnerable
trixie5.6.6-1.2vulnerable
sid5.6.6-1.3vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
wolfsslsource(unstable)(unfixed)1067799

Notes

[bookworm] - wolfssl <no-dsa> (Minor issue)
[bullseye] - wolfssl <no-dsa> (Minor issue)
https://github.com/wolfSSL/wolfssl/issues/7089
https://github.com/wolfSSL/wolfssl/pull/7099

Search for package or bug name: Reporting problems