CVE-2024-1062

NameCVE-2024-1062
DescriptionA heap overflow flaw was found in 389-ds-base. This issue leads to a denial of service when writing a value larger than 256 chars in log_entry_attr.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
389-ds-base (PTS)buster1.4.0.21-1vulnerable
buster (security)1.4.0.21-1+deb10u1vulnerable
bullseye1.4.4.11-2vulnerable
bookworm2.3.1+dfsg1-1vulnerable
sid, trixie2.4.4+dfsg1-3vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
389-ds-basesource(unstable)(unfixed)

Notes

[bookworm] - 389-ds-base <no-dsa> (Minor issue)
[bullseye] - 389-ds-base <no-dsa> (Minor issue)
[buster] - 389-ds-base <no-dsa> (Minor issue)
https://bugzilla.redhat.com/show_bug.cgi?id=2261879
https://bugzilla.redhat.com/show_bug.cgi?id=2256711
https://github.com/389ds/389-ds-base/issues/5647

Search for package or bug name: Reporting problems