CVE-2024-1433

NameCVE-2024-1433
DescriptionA vulnerability, which was classified as problematic, was found in KDE Plasma Workspace up to 5.93.0. This affects the function EventPluginsManager::enabledPlugins of the file components/calendar/eventpluginsmanager.cpp of the component Theme File Handler. The manipulation of the argument pluginId leads to path traversal. It is possible to initiate the attack remotely. The complexity of an attack is rather high. The exploitability is told to be difficult. The patch is named 6cdf42916369ebf4ad5bd876c4dfa0170d7b2f01. It is recommended to apply a patch to fix this issue. The associated identifier of this vulnerability is VDB-253407. NOTE: This requires write access to user's home or the installation of third party global themes.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
plasma-workspace (PTS)buster4:5.14.5.1-1fixed
buster (security)4:5.14.5.1-1+deb10u1fixed
bullseye4:5.20.5-6fixed
bookworm4:5.27.5-2+deb12u1fixed
sid, trixie4:5.27.11.1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
plasma-workspacesource(unstable)(not affected)

Notes

- plasma-workspace <not-affected> (Vulnerable code introduced later)
Fixed by: https://github.com/KDE/plasma-workspace/commit/6cdf42916369ebf4ad5bd876c4dfa0170d7b2f01 (v6.0.90)
Introduced by: https://github.com/KDE/plasma-workspace/commit/23940dbb90b99e96ebeaede14779d2582634bde3 (5.93.0)
Prior versions don't use 'pluginId' but the full path plugin directly (without path construction/traversal)

Search for package or bug name: Reporting problems