DescriptionVersions of the package sanitize-html before 2.12.1 are vulnerable to Information Exposure when used on the backend and with the style attribute allowed, allowing enumeration of files in the system (including project dependencies). An attacker could exploit this vulnerability to gather details about the file system structure and dependencies of the targeted server.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
Debian Bugs1064808

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
node-sanitize-html (PTS)sid, trixie, bookworm2.8.0+~2.6.2-1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs


[bookworm] - node-sanitize-html <no-dsa> (Minor issue) (2.12.1) (2.12.1)

Search for package or bug name: Reporting problems