CVE-2024-21506

NameCVE-2024-21506
DescriptionVersions of the package pymongo before 4.6.3 are vulnerable to Out-of-bounds Read in the bson module. Using the crafted payload the attacker could force the parser to deserialize unmanaged memory. The parser tries to interpret bytes next to buffer and throws an exception with string. If the following bytes are not printable UTF-8 the parser throws an exception with a single byte.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
Debian Bugs1069581

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
pymongo (PTS)buster3.7.1-1.1vulnerable
sid, trixie, bookworm, bullseye3.11.0-1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
pymongosource(unstable)(unfixed)1069581

Notes

[bookworm] - pymongo <no-dsa> (Minor issue)
[bullseye] - pymongo <no-dsa> (Minor issue)
[buster] - pymongo <postponed> (Minor issue)
https://security.snyk.io/vuln/SNYK-PYTHON-PYMONGO-6370597
https://gist.github.com/keltecc/62a7c2bf74a997d0a7b48a0ff3853a03

Search for package or bug name: Reporting problems