CVE-2024-22365

NameCVE-2024-22365
Descriptionlinux-pam (aka Linux PAM) before 1.6.0 allows attackers to cause a denial of service (blocked login process) via mkfifo because the openat call (for protect_dir) lacks O_DIRECTORY.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
Debian Bugs1061097

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
pam (PTS)buster1.3.1-5vulnerable
bullseye1.4.0-9+deb11u1vulnerable
bookworm1.5.2-6+deb12u1vulnerable
trixie1.5.2-9.1vulnerable
sid1.5.3-6fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
pamsourceexperimental1.5.3-2
pamsource(unstable)1.5.3-41061097

Notes

[bookworm] - pam <no-dsa> (Minor issue)
[bullseye] - pam <no-dsa> (Minor issue)
[buster] - pam <no-dsa> (Minor issue)
https://www.openwall.com/lists/oss-security/2024/01/18/3
https://github.com/linux-pam/linux-pam/commit/031bb5a5d0d950253b68138b498dc93be69a64cb (v1.6.0)

Search for package or bug name: Reporting problems