CVE-2024-22563

NameCVE-2024-22563
Descriptionopenvswitch 2.17.8 was discovered to contain a memory leak via the function xmalloc__ in openvswitch-2.17.8/lib/util.c.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
openvswitch (PTS)buster2.10.7+ds1-0+deb10u1fixed
buster (security)2.10.7+ds1-0+deb10u5fixed
bullseye (security), bullseye2.15.0+ds1-2+deb11u4vulnerable
bookworm3.1.0-2fixed
trixie3.3.0~git20240118.e802fe7-3fixed
sid3.3.0-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
openvswitchsourcebuster(not affected)
openvswitchsource(unstable)2.17.2-4

Notes

[bullseye] - openvswitch <no-dsa> (Minor issue)
[buster] - openvswitch <not-affected> (Vulnerable code introduced later)
https://github.com/openvswitch/ovs-issues/issues/315
https://github.com/openvswitch/ovs/commit/3168f328c78cf6e4b3022940452673b0e49f7620 (v2.17.0)
Introduced with: https://github.com/openvswitch/ovs/commit/b6e840aed03e3f6d1aa726b482140d895f60f90f (v2.11.0)

Search for package or bug name: Reporting problems