CVE-2024-22860

NameCVE-2024-22860
DescriptionInteger overflow vulnerability in FFmpeg before n6.1, allows remote attackers to execute arbitrary code via the jpegxl_anim_read_packet component in the JPEG XL Animation decoder.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
ffmpeg (PTS)buster7:4.1.9-0+deb10u1fixed
buster (security)7:4.1.11-0+deb10u1fixed
bullseye (security), bullseye7:4.3.6-0+deb11u1fixed
bookworm, bookworm (security)7:5.1.4-0+deb12u1fixed
trixie7:6.1.1-1fixed
sid7:6.1.1-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
ffmpegsourcebuster(not affected)
ffmpegsourcebullseye(not affected)
ffmpegsourcebookworm(not affected)
ffmpegsource(unstable)7:6.1-1

Notes

[bookworm] - ffmpeg <not-affected> (jpegxl support added in 6.1)
[bullseye] - ffmpeg <not-affected> (jpegxl support added in 6.1)
[buster] - ffmpeg <not-affected> (jpegxl support added in 6.1)
https://github.com/FFmpeg/FFmpeg/commit/d2e8974699a9e35cc1a926bf74a972300d629cd5 (n6.1)
https://bugs.chromium.org/p/oss-fuzz/issues/detail?id=61991

Search for package or bug name: Reporting problems