CVE-2024-23342

NameCVE-2024-23342
DescriptionThe `ecdsa` PyPI package is a pure Python implementation of ECC (Elliptic Curve Cryptography) with support for ECDSA (Elliptic Curve Digital Signature Algorithm), EdDSA (Edwards-curve Digital Signature Algorithm) and ECDH (Elliptic Curve Diffie-Hellman). Versions 0.18.0 and prior are vulnerable to the Minerva attack. As of time of publication, no known patched version exists.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
python-ecdsa (PTS)buster, buster (security)0.13-3+deb10u1vulnerable
bullseye0.16.1-1vulnerable
bookworm0.18.0-3vulnerable
sid, trixie0.18.0-5vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
python-ecdsasource(unstable)(unfixed)unimportant

Notes

https://github.com/tlsfuzzer/python-ecdsa/security/advisories/GHSA-wj6h-64fc-37mp
https://minerva.crocs.fi.muni.cz/
Side channel attacks not covered by their security policy:
https://github.com/tlsfuzzer/python-ecdsa/blob/master/SECURITY.md

Search for package or bug name: Reporting problems