CVE-2024-23744

NameCVE-2024-23744
DescriptionAn issue was discovered in Mbed TLS 3.5.1. There is persistent handshake denial if a client sends a TLS 1.3 ClientHello without extensions.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
mbedtls (PTS)buster2.16.0-1vulnerable
buster (security)2.16.9-0~deb10u1vulnerable
bullseye2.16.9-0.1vulnerable
bookworm2.28.3-1vulnerable
sid, trixie2.28.7-1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
mbedtlssource(unstable)(unfixed)

Notes

[bookworm] - mbedtls <no-dsa> (Minor issue)
[bullseye] - mbedtls <no-dsa> (Minor issue)
[buster] - mbedtls <postponed> (Minor issue)
https://github.com/Mbed-TLS/mbedtls/issues/8694
https://github.com/Mbed-TLS/mbedtls/pull/8595
Likely specific to 3.5.1: https://github.com/Mbed-TLS/mbedtls/issues/8694#issuecomment-1889411367

Search for package or bug name: Reporting problems