CVE-2024-23831

NameCVE-2024-23831
DescriptionLedgerSMB is a free web-based double-entry accounting system. When a LedgerSMB database administrator has an active session in /setup.pl, an attacker can trick the admin into clicking on a link which automatically submits a request to setup.pl without the admin's consent. This request can be used to create a new user account with full application (/login.pl) privileges, leading to privilege escalation. The vulnerability is patched in versions 1.10.30 and 1.11.9.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
Debian Bugs1062845

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
ledgersmb (PTS)buster, buster (security)1.6.9+ds-1+deb10u3vulnerable
bullseye (security), bullseye1.6.9+ds-2+deb11u3vulnerable
trixie, sid, bookworm1.6.33+ds-2.1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
ledgersmbsource(unstable)(unfixed)1062845

Notes

[bookworm] - ledgersmb <no-dsa> (Minor issue)
[bullseye] - ledgersmb <no-dsa> (Minor issue)
[buster] - ledgersmb <no-dsa> (Minor issue)
https://github.com/ledgersmb/LedgerSMB/security/advisories/GHSA-98ff-f638-qxjm
https://github.com/ledgersmb/LedgerSMB/commit/8c2ae5be68a782d62cb9c0e17c0127bf30ef4165

Search for package or bug name: Reporting problems