CVE-2024-23837

NameCVE-2024-23837
DescriptionLibHTP is a security-aware parser for the HTTP protocol. Crafted traffic can cause excessive processing time of HTTP headers, leading to denial of service. This issue is addressed in 0.5.46.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libhtp (PTS)buster1:0.5.30-1vulnerable
bullseye1:0.5.36-1vulnerable
bookworm1:0.5.42-1vulnerable
sid, trixie1:0.5.48-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libhtpsource(unstable)1:0.5.46-1

Notes

[bookworm] - libhtp <no-dsa> (Minor issue)
[bullseye] - libhtp <no-dsa> (Minor issue)
[buster] - libhtp <no-dsa> (Minor issue)
https://github.com/OISF/libhtp/security/advisories/GHSA-f9wf-rrjj-qx8m
https://github.com/OISF/libhtp/commit/20ac301d801cdf01b3f021cca08a22a87f477c4a (0.5.46)
https://redmine.openinfosecfoundation.org/issues/6444

Search for package or bug name: Reporting problems