CVE-2024-24549

NameCVE-2024-24549
DescriptionDenial of Service due to improper input validation vulnerability for HTTP/2 requests in Apache Tomcat. When processing an HTTP/2 request, if the request exceeded any of the configured limits for headers, the associated HTTP/2 stream was not reset until after all of the headers had been processed.This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.0-M16, from 10.1.0-M1 through 10.1.18, from 9.0.0-M1 through 9.0.85, from 8.5.0 through 8.5.98. Users are recommended to upgrade to version 11.0.0-M17, 10.1.19, 9.0.86 or 8.5.99 which fix the issue.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
ReferencesDLA-3779-1, DSA-5665-1
Debian Bugs1066878

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
tomcat10 (PTS)bookworm10.1.6-1+deb12u1vulnerable
bookworm (security)10.1.6-1+deb12u2fixed
trixie, sid10.1.20-1fixed
tomcat9 (PTS)buster9.0.31-1~deb10u6vulnerable
buster (security)9.0.31-1~deb10u12fixed
bullseye (security), bullseye9.0.43-2~deb11u9vulnerable
trixie, sid, bookworm9.0.70-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
tomcat10sourcebookworm10.1.6-1+deb12u2DSA-5665-1
tomcat10source(unstable)10.1.20-11066878
tomcat9sourcebuster9.0.31-1~deb10u12DLA-3779-1
tomcat9source(unstable)9.0.70-2

Notes

https://lists.apache.org/thread/4c50rmomhbbsdgfjsgwlb51xdwfjdcvg
https://github.com/apache/tomcat/commit/d07c82194edb69d99b438828fe2cbfadbb207843 (10.1.19)
https://github.com/apache/tomcat/commit/8e03be9f2698f2da9027d40b9e9c0c9429b74dc0 (9.0.86)
Starting with 9.0.70-2 Tomcat9 no longer ships the server stack, using that as the fixed version

Search for package or bug name: Reporting problems