CVE-2024-24821

NameCVE-2024-24821
DescriptionComposer is a dependency Manager for the PHP language. In affected versions several files within the local working directory are included during the invocation of Composer and in the context of the executing user. As such, under certain conditions arbitrary code execution may lead to local privilege escalation, provide lateral user movement or malicious code execution when Composer is invoked within a directory with tampered files. All Composer CLI commands are affected, including composer.phar's self-update. The following scenarios are of high risk: Composer being run with sudo, Pipelines which may execute Composer on untrusted projects, Shared environments with developers who run Composer individually on the same project. This vulnerability has been addressed in versions 2.7.0 and 2.2.23. It is advised that the patched versions are applied at the earliest convenience. Where not possible, the following should be addressed: Remove all sudo composer privileges for all users to mitigate root privilege escalation, and avoid running Composer within an untrusted directory, or if needed, verify that the contents of `vendor/composer/InstalledVersions.php` and `vendor/composer/installed.php` do not include untrusted code. A reset can also be done on these files by the following:```sh rm vendor/composer/installed.php vendor/composer/InstalledVersions.php composer install --no-scripts --no-plugins ```
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
ReferencesDSA-5632-1
Debian Bugs1063603

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
composer (PTS)buster1.8.4-1+deb10u2vulnerable
buster (security)1.8.4-1+deb10u1vulnerable
bullseye2.0.9-2+deb11u1vulnerable
bullseye (security)2.0.9-2+deb11u2fixed
bookworm2.5.5-1vulnerable
bookworm (security)2.5.5-1+deb12u1fixed
sid, trixie2.7.1-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
composersourcebullseye2.0.9-2+deb11u2DSA-5632-1
composersourcebookworm2.5.5-1+deb12u1DSA-5632-1
composersource(unstable)2.7.1-11063603

Notes

https://github.com/composer/composer/security/advisories/GHSA-7c6p-848j-wh5h
https://github.com/composer/composer/commit/64e4eb356b159a30c766cd1ea83450a38dc23bf5 (2.7.0)

Search for package or bug name: Reporting problems