CVE-2024-25581

NameCVE-2024-25581
DescriptionWhen incoming DNS over HTTPS support is enabled using the nghttp2 provider, and queries are routed to a tcp-only or DNS over TLS backend, an attacker can trigger an assertion failure in DNSdist by sending a request for a zone transfer (AXFR or IXFR) over DNS over HTTPS, causing the process to stop and thus leading to a Denial of Service. DNS over HTTPS is not enabled by default, and backends are using plain DNS (Do53) by default.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
Debian Bugs1071750

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
dnsdist (PTS)buster1.3.3-3fixed
bullseye1.5.1-3fixed
bookworm1.7.3-2fixed
trixie1.9.3-1vulnerable
sid1.9.4-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
dnsdistsourcebuster(not affected)
dnsdistsourcebullseye(not affected)
dnsdistsourcebookworm(not affected)
dnsdistsource(unstable)1.9.4-11071750

Notes

[bookworm] - dnsdist <not-affected> (Vulnerable code not present)
[bullseye] - dnsdist <not-affected> (Vulnerable code not present)
[buster] - dnsdist <not-affected> (Vulnerable code not present)
https://dnsdist.org/security-advisories/powerdns-advisory-for-dnsdist-2024-03.html
Patches: https://downloads.powerdns.com/patches/2024-03/

Search for package or bug name: Reporting problems