CVE-2024-26146

NameCVE-2024-26146
DescriptionRack is a modular Ruby web server interface. Carefully crafted headers can cause header parsing in Rack to take longer than expected resulting in a possible denial of service issue. Accept and Forwarded headers are impacted. Ruby 3.2 has mitigations for this problem, so Rack applications using Ruby 3.2 or newer are unaffected. This vulnerability is fixed in 2.0.9.4, 2.1.4.4, 2.2.8.1, and 3.0.9.1.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
ReferencesDLA-3800-1, DSA-5698-1
Debian Bugs1064516

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
ruby-rack (PTS)buster2.0.6-3vulnerable
buster (security)2.0.6-3+deb10u4fixed
bullseye2.1.4-3+deb11u1vulnerable
bullseye (security)2.1.4-3+deb11u2fixed
bookworm2.2.6.4-1vulnerable
bookworm (security)2.2.6.4-1+deb12u1fixed
sid, trixie2.2.7-1.1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
ruby-racksourcebuster2.0.6-3+deb10u4DLA-3800-1
ruby-racksourcebullseye2.1.4-3+deb11u2DSA-5698-1
ruby-racksourcebookworm2.2.6.4-1+deb12u1DSA-5698-1
ruby-racksource(unstable)2.2.7-1.11064516

Notes

https://github.com/rack/rack/releases/tag/v2.2.8.1
https://github.com/rack/rack/commit/e4c117749ba24a66f8ec5a08eddf68deeb425ccd (v2.2.8.1)

Search for package or bug name: Reporting problems