CVE-2024-26462

NameCVE-2024-26462
DescriptionKerberos 5 (aka krb5) 1.21.2 contains a memory leak vulnerability in /krb5/src/kdc/ndr.c.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
Debian Bugs1064965

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
krb5 (PTS)bullseye1.18.3-6+deb11u4vulnerable
bullseye (security)1.18.3-6+deb11u5vulnerable
bookworm1.20.1-2+deb12u1vulnerable
bookworm (security)1.20.1-2+deb12u2vulnerable
trixie1.21.2-1vulnerable
sid1.21.3-3vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
krb5source(unstable)(unfixed)1064965

Notes

[bookworm] - krb5 <no-dsa> (Minor issue)
[bullseye] - krb5 <no-dsa> (Minor issue)
[buster] - krb5 <no-dsa> (Minor issue)
https://github.com/LuMingYinDetect/krb5_defects/blob/main/krb5_detect_3.md

Search for package or bug name: Reporting problems