CVE-2024-27913

NameCVE-2024-27913
Descriptionospf_te_parse_te in ospfd/ospf_te.c in FRRouting (FRR) through 9.1 allows remote attackers to cause a denial of service (ospfd daemon crash) via a malformed OSPF LSA packet, because of an attempted access to a missing attribute field.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
Debian Bugs1065144

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
frr (PTS)buster6.0.2-2+deb10u1vulnerable
buster (security)7.5.1-1.1+deb10u1vulnerable
bullseye (security), bullseye7.5.1-1.1+deb11u2vulnerable
bookworm, bookworm (security)8.4.4-1.1~deb12u1vulnerable
sid9.1-0.1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
frrsource(unstable)9.1-0.11065144

Notes

https://github.com/FRRouting/frr/pull/15431
stable/9.0: https://github.com/FRRouting/frr/commit/aae54e20498974cb026bd0e2649ca3e753090492 (

Search for package or bug name: Reporting problems