CVE-2024-28085

NameCVE-2024-28085
Descriptionwall in util-linux through 2.40, often installed with setgid tty permissions, allows escape sequences to be sent to other users' terminals through argv. (Specifically, escape sequences received from stdin are blocked, but escape sequences received from argv are not blocked.) There may be plausible scenarios where this leads to account takeover.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
ReferencesDLA-3782-1, DSA-5650-1
Debian Bugs1067849

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
util-linux (PTS)buster2.33.1-0.1vulnerable
buster (security)2.33.1-0.1+deb10u1fixed
bullseye2.36.1-8+deb11u1vulnerable
bullseye (security)2.36.1-8+deb11u2fixed
bookworm2.38.1-5vulnerable
bookworm (security)2.38.1-5+deb12u1fixed
trixie2.39.3-6vulnerable
sid2.40-6fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
util-linuxsourcebuster2.33.1-0.1+deb10u1DLA-3782-1
util-linuxsourcebullseye2.36.1-8+deb11u2DSA-5650-1
util-linuxsourcebookworm2.38.1-5+deb12u1DSA-5650-1
util-linuxsource(unstable)2.39.3-111067849

Notes

https://www.openwall.com/lists/oss-security/2024/03/27/5
https://github.com/util-linux/util-linux/commit/404b0781f52f7c045ca811b2dceec526408ac253 (v2.40)

Search for package or bug name: Reporting problems