CVE-2024-28219

NameCVE-2024-28219
DescriptionIn _imagingcms.c in Pillow before 10.3.0, a buffer overflow exists because strcpy is used instead of strncpy.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
ReferencesDLA-3786-1, DSA-5704-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
pillow (PTS)buster5.4.1-2+deb10u3vulnerable
buster (security)5.4.1-2+deb10u6fixed
bullseye8.1.2+dfsg-0.3+deb11u1vulnerable
bullseye (security)8.1.2+dfsg-0.3+deb11u2fixed
bookworm9.4.0-1.1vulnerable
bookworm (security)9.4.0-1.1+deb12u1fixed
sid, trixie10.3.0-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
pillowsourcebuster5.4.1-2+deb10u6DLA-3786-1
pillowsourcebullseye8.1.2+dfsg-0.3+deb11u2DSA-5704-1
pillowsourcebookworm9.4.0-1.1+deb12u1DSA-5704-1
pillowsource(unstable)10.3.0-1

Notes

https://pillow.readthedocs.io/en/stable/releasenotes/10.3.0.html#security
https://github.com/python-pillow/Pillow/commit/2a93aba5cfcf6e241ab4f9392c13e3b74032c061 (10.3.0)

Search for package or bug name: Reporting problems