CVE-2024-28243

NameCVE-2024-28243
DescriptionKaTeX is a JavaScript library for TeX math rendering on the web. KaTeX users who render untrusted mathematical expressions could encounter malicious input using `\edef` that causes a near-infinite loop, despite setting `maxExpand` to avoid such loops. This can be used as an availability attack, where e.g. a client rendering another user's KaTeX input will be unable to use the site due to memory overflow, tying up the main thread, or stack overflow. Upgrade to KaTeX v0.16.10 to remove this vulnerability.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
Debian Bugs1067805

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
node-katex (PTS)bullseye0.10.2+dfsg-8vulnerable
bookworm0.16.4+~cs6.1.0-1vulnerable
trixie, sid0.16.10+~cs6.1.0-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
node-katexsource(unstable)0.16.10+~cs6.1.0-11067805

Notes

[bookworm] - node-katex <no-dsa> (Minor issue)
[bullseye] - node-katex <no-dsa> (Minor issue)
https://github.com/KaTeX/KaTeX/security/advisories/GHSA-64fm-8hw2-v72w
https://github.com/KaTeX/KaTeX/commit/e88b4c357f978b1bca8edfe3297f0aa309bcbe34 (v0.16.10)

Search for package or bug name: Reporting problems