CVE-2024-28863

NameCVE-2024-28863
Descriptionnode-tar is a Tar for Node.js. node-tar prior to version 6.2.1 has no limit on the number of sub-folders created in the folder creation process. An attacker who generates a large number of sub-folders can consume memory on the system running node-tar and even crash the Node.js client within few seconds of running it using a path with too many sub-folders inside. Version 6.2.1 fixes this issue by preventing extraction in excessively deep sub-folders.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
node-tar (PTS)buster4.4.6+ds1-3+deb10u1vulnerable
buster (security)4.4.6+ds1-3+deb10u2vulnerable
bullseye (security), bullseye6.0.5+ds1+~cs11.3.9-1+deb11u2vulnerable
bookworm6.1.13+~cs7.0.5-1vulnerable
sid, trixie6.1.13+~cs7.0.5-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
node-tarsource(unstable)6.1.13+~cs7.0.5-2

Notes

[bookworm] - node-tar <no-dsa> (Minor issue)
[bullseye] - node-tar <no-dsa> (Minor issue)
https://github.com/isaacs/node-tar/security/advisories/GHSA-f5x3-32g6-xq36
https://github.com/isaacs/node-tar/commit/fe8cd57da5686f8695415414bda49206a545f7f7 (v6.2.1)

Search for package or bug name: Reporting problems