CVE-2024-29025

NameCVE-2024-29025
DescriptionNetty is an asynchronous event-driven network application framework for rapid development of maintainable high performance protocol servers & clients. The `HttpPostRequestDecoder` can be tricked to accumulate data. While the decoder can store items on the disk if configured so, there are no limits to the number of fields the form can have, an attacher can send a chunked post consisting of many small fields that will be accumulated in the `bodyListHttpData` list. The decoder cumulates bytes in the `undecodedChunk` buffer until it can decode a field, this field can cumulate data without limits. This vulnerability is fixed in 4.1.108.Final.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
Debian Bugs1068110

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
netty (PTS)buster1:4.1.33-1+deb10u2vulnerable
buster (security)1:4.1.33-1+deb10u4vulnerable
bullseye (security), bullseye1:4.1.48-4+deb11u2vulnerable
bookworm, bookworm (security)1:4.1.48-7+deb12u1vulnerable
trixie, sid1:4.1.48-9vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
nettysource(unstable)(unfixed)1068110

Notes

[bookworm] - netty <postponed> (Minor issue, fix along with future update)
[bullseye] - netty <postponed> (Minor issue, fix along with future update)
https://github.com/netty/netty/security/advisories/GHSA-5jpm-x58v-624v
https://github.com/netty/netty/commit/0d0c6ed782d13d423586ad0c71737b2c7d02058c (netty-4.1.108.Final)
https://gist.github.com/vietj/f558b8ea81ec6505f1e9a6ca283c9ae3

Search for package or bug name: Reporting problems