CVE-2024-2947

NameCVE-2024-2947
DescriptionA flaw was found in Cockpit. Deleting a sosreport with a crafted name via the Cockpit web interface can lead to a command injection vulnerability, resulting in privilege escalation. This issue affects Cockpit versions 270 and newer.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
ReferencesDSA-5655-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
cockpit (PTS)buster188-1fixed
bullseye239-1fixed
bookworm287-1vulnerable
bookworm (security)287.1-0+deb12u1fixed
trixie311-1vulnerable
sid314-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
cockpitsourcebuster(not affected)
cockpitsourcebullseye(not affected)
cockpitsourcebookworm287.1-0+deb12u1DSA-5655-1
cockpitsource(unstable)314-1

Notes

[bullseye] - cockpit <not-affected> (Vulnerable code not present)
[buster] - cockpit <not-affected> (Vulnerable code not present)
https://bugzilla.redhat.com/show_bug.cgi?id=2271614
https://github.com/cockpit-project/cockpit/pull/20232
Introduced by: https://github.com/cockpit-project/cockpit/commit/ee8f946df39779ee37071006d1d4826317f25c9a (270)
Fixed by: https://github.com/cockpit-project/cockpit/commit/9c4cc9b6df632082538b53bdc8ee9ec1c5cad4da (314)

Search for package or bug name: Reporting problems